Incoming and Outgoing E-mail error

Apr 8, 2008 at 2:32 PM
Hi

Does anyone the reason why tests of Incoming and Outgoing E-mail occurs error?
In particular, the tests are IncomingSalesTest, IncomingSupportTest and OutgoingTest included in LoadTestOutlookDM.loadtest in CRMPerfBenchMark solution. The error message is like the following:

  • Warning: Test Run deployment issue: The assembly or module 'Microsoft.Crm.Application.Components.Platform' directly or indirectly referenced by test assembly 'c:\crm 4.0 toolkit\crm4perftoolkit\crmperfbenchmark\bin\debug\crmperfbenchmark.dll' was not found.
  • Warning: Test Run deployment issue: The assembly or module 'Microsoft.Crm.Setup.DiffBuilder' directly or indirectly referenced by test assembly 'c:\crm 4.0 toolkit\crm4perftoolkit\crmperfbenchmark\bin\debug\crmperfbenchmark.dll' was not found.

All the three tests failed with the above error messages.

Best regards,
Keiji
Apr 9, 2008 at 5:00 AM
I respond by myself. This was resolved. In the other new environment, the error was not occurred.
I will close this discussion.

Thank you,
Keiji
Apr 18, 2008 at 8:02 PM

Hi Keiji,
If you see such missing dll errors in general, place the missing dlls in the same folder as the CRM_Perf_Benchmark.dll and that issue should be resolved.

Thanks,
Aditya.
Jan 13, 2009 at 8:17 PM
Hello - we just ran into this issue as well, the cause of the problem is an incorrect vstesthost.exe.config file.  Ensure the xml doc is parsable and the correct value is in that file.

Hope this helps!

Sean