Error after running the RunPopulate.cmd or Runpopulate2.cmd in MS CRM 2011 Performance Toolkit

Aug 21, 2013 at 12:12 PM
Hi All,

I am facing problem while running the RunPopulate.cmd or Runpopulate2.cmd, as this command is importing the solutions in CRM but after that when it moves to DBPopulator\dbpopulator.exe UserPopulate.xml it starts failing and gives error message as :-

C:\CRMToolkit\Binaries\DbPopulator\dbPopulator.exe UerPopulate.xml
System.Security.SecurityException: Requested registry access is not allowed.
at Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable)
at System.Diagnostics.PerformanceCounterLib.CreateRegistryEntry(String categoryName, PerformanceCounterCategoryType categoryType, CounterCreationDataCollection creationData, Boolean& iniRegistered)
at System.Diagnostics.PerformanceCounterLib.RegisterCategory(String categoryName, PerformanceCounterCategoryType categoryType, String categoryHelp, CounterCreationDataCollection creationData)
at System.Diagnostics.PerformanceCounterCategory.Create(String categoryName, String categoryHelp, PerformanceCounterCategoryType categoryType, CounterCreationDataCollection counterData)
at dbPopulator.DbPopulator.Main(String[] args)
The Zone of the assembly that failed was:
MyComputer


Please let me know if i am missing something and guide me.
Nov 20, 2013 at 10:05 PM
Try to run the .cmd file with Administrator privileges. Start ---> Cmd (Run as administrator). Then run the Runpopulation.cmd from the cmd window.